Revert modifications for Fedora compatibility due to stability problems.
[synfig.git] / ETL / trunk / ETL / Makefile.am
index ffa8f64..b08fdcf 100644 (file)
@@ -3,10 +3,9 @@
 MAINTAINERCLEANFILES = \
        Makefile.in
 
+CLEANFILES = \
+       $(top_builddir)/ETL/etl_profile.h
 
-etlconfigdir = $(libdir)/ETL/include
-
-etlconfig_DATA = etl_profile.h
 
 etldir = $(includedir)/ETL
 
@@ -56,6 +55,7 @@ etl_HEADERS = \
        _trivial.h \
        _fixed.h \
        etl_config.h \
+       $(top_builddir)/ETL/etl_profile.h \
        _fastangle_tables.h \
        bezier \
        _bezier.h \
@@ -77,6 +77,10 @@ etl_HEADERS = \
        _mutex_pthreads_simple.h
 
 
+$(top_builddir)/ETL/etl_profile.h:$(top_builddir)/ETL/etl_profile_.h
+       sed "s/PACKAGE/ETL/g;" < $(top_builddir)/ETL/etl_profile_.h > $(top_builddir)/ETL/etl_profile.h
+
+
 # FIXME: figure out why this is in SVN, but isn't installed
 EXTRA_DIST = \
        _bit_rotate.h