Add some changes to make ETL more suitable for Fedora:
[synfig.git] / ETL / trunk / Makefile.am
index 11516b4..40d9abf 100644 (file)
@@ -1,21 +1,58 @@
 # $Id$
 
-MAINTAINERCLEANFILES=config/config.guess config/config.sub config/ltmain.sh config/install-sh config/mkinstalldirs config/aclocal.m4 config/missing config/texinfo.tex config/depcomp aclocal.m4 config.h.in configure stamp-h.in Makefile.in config.log config.status .doc_stamp .DS_Store @PACKAGE@.spec include/etl_profile.h.in
+MAINTAINERCLEANFILES = \
+       COPYING \
+       INSTALL \
+       config/config.guess \
+       config/config.sub \
+       config/ltmain.sh \
+       config/install-sh \
+       config/mkinstalldirs \
+       config/aclocal.m4 \
+       config/missing \
+       config/texinfo.tex \
+       config/depcomp \
+       aclocal.m4 \
+       config.h.in \
+       configure \
+       stamp-h.in \
+       Makefile.in \
+       config.log \
+       config.status \
+       .doc_stamp \
+       .DS_Store \
+       doxygen.cfg
+
+
+SUBDIRS = \
+       ETL \
+       test
 
-SUBDIRS=ETL test
 
 # Install the pkg-config file:
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = ETL.pc
 
 #Install the -config/m4 alternative to pkg-config:
-bin_SCRIPTS=ETL-config
-aclocaldir = $(prefix)/share/aclocal
+bin_SCRIPTS = ETL-config
 
+aclocaldir = $(prefix)/share/aclocal
+ACLOCAL_AMFLAGS = -I m4
+
+EXTRA_DIST = \
+       COPYING \
+       m4/subs.m4 \
+       config/depcomp \
+       m4/cxx_macros.m4 \
+       ETL.pbproj/project.pbxproj \
+       ETL.pbproj/frameworkfix.cpp \
+       ETL-config.in \
+       m4/ETL.m4 \
+       doxygen.cfg.in \
+       doxygen.cfg \
+       ETL.pc.in
 
-EXTRA_DIST=COPYING bootstrap config/subs.m4 config/depcomp config/cxx_macros.m4 ETL.pbproj/project.pbxproj ETL.pbproj/etl_profile.h ETL.pbproj/frameworkfix.cpp @PACKAGE_TARNAME@.spec config/project.spec.in config/build.cfg ETL-config.in config/ETL.m4 config/doxygen.cfg.in doxygen.cfg config/pkgconfig.pc.in @PACKAGE_TARNAME@.pc.in
 
-CVS=cvs
 SVN=svn
 TAG=@PACKAGE_TARNAME@_@VERSION_MAJ@_@VERSION_MIN@_@VERSION_REV@
 
@@ -38,14 +75,15 @@ stats:
        -@echo 
 
 tagstable:
-       -$(SVN) delete $(SVN_REPOSITORY)/tags/stable -m "Stabe Tag: Removing old tag"
-       $(SVN) mkdir $(SVN_REPOSITORY)/tags/stable -m "Stable Tag: Creating new directory"
-       $(SVN) copy $(top_srcdir) $(SVN_REPOSITORY)/tags/stable -m "Stable Tag: Copying everyhting over"
+       -$(SVN) delete $(SVN_REPOSITORY)/tags/stable -m "Stable Tag: Removing old tag"
+       $(SVN) copy $(top_srcdir) $(SVN_REPOSITORY)/tags/stable -m "Stable Tag: Copying everything over"
 
 tagrelease:
-       $(SVN) mkdir $(SVN_REPOSITORY)/tags/$(TAG) -m "Release Tag: Making directory"
        $(SVN) copy $(top_srcdir) $(SVN_REPOSITORY)/tags/$(TAG) -m "Release $(TAG)"
 
+ChangeLog:
+       -svn update
+       svn2cl --include-rev || touch ChangeLog
 
 listfixmes:
        -@echo
@@ -63,9 +101,6 @@ listhacks:
 
 run: check
 
-$(srcdir)/configure:  $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
-       $(srcdir)/bootstrap
-
 .doc_stamp: doxygen.cfg
        $(DOXYGEN) doxygen.cfg
        touch .doc_stamp