Revert modifications for Fedora compatibility due to stability problems.
[synfig.git] / ETL / trunk / configure.ac
index 00de6b3..63f5e96 100644 (file)
@@ -2,11 +2,11 @@
 
 # -- I N I T --------------------------------------------------
 
-AC_INIT([Extended Template Library],[0.04.11],[http://synfig.org/Bugs],[ETL])
+AC_INIT([Extended Template Library],[0.04.12],[http://synfig.org/Bugs],[ETL])
 AC_REVISION
 
 AC_CONFIG_AUX_DIR(config)
-AM_CONFIG_HEADER(ETL/etl_profile_.h)
+AC_CONFIG_HEADERS([ETL/etl_profile_.h])
 AC_CANONICAL_HOST
 AC_CANONICAL_TARGET
 
@@ -17,7 +17,7 @@ AM_MAINTAINER_MODE
 
 debug="no"
 
-SVN_REPOSITORY=http://svn.voria.com/code/ETL
+SVN_REPOSITORY=https://synfig.svn.sourceforge.net/svnroot/synfig/ETL
 AC_SUBST(SVN_REPOSITORY)
 
 # -- A R G U M E N T S ----------------------------------------
@@ -30,7 +30,7 @@ AC_PROG_CXX
 AC_PROG_INSTALL
 AC_PROG_RANLIB
 
-AC_LANG_CPLUSPLUS
+AC_LANG([C++])
 
 AC_ARG_WARNINGS
 AC_ARG_DEBUG
@@ -62,9 +62,6 @@ AH_BOTTOM([
 # -- F U N C T I O N S ----------------------------------------
 
 ETL_DEPS
-AC_CHECK_FUNCS([fork])
-AC_CHECK_FUNCS([kill])
-AC_CHECK_FUNCS([pipe])
 
 # -- O U T P U T ----------------------------------------------
 
@@ -72,14 +69,14 @@ AC_SUBST(CFLAGS)
 AC_SUBST(CPPFLAGS)
 AC_SUBST(LDFLAGS)
 
-AC_OUTPUT(
-ETL-config
+AC_CONFIG_FILES([ETL-config
 Makefile
 ETL/Makefile
 test/Makefile
 ETL.pc
 doxygen.cfg
-)
+])
+AC_OUTPUT
 
 # -- S U M M A R Y --------------------------------------------