Mofidy files to point to release 0.62.02
[synfig.git] / synfig-core / configure.ac
index 3f1b7b6..2726d4c 100644 (file)
@@ -2,7 +2,7 @@
 
 # -- I N I T --------------------------------------------------
 
-AC_INIT([Synfig Core],[0.61.09],[http://synfig.org/Bugs],[synfig])
+AC_INIT([Synfig Core],[0.62.02],[http://sourceforge.net/tracker/?group_id=144022&atid=757416],[synfig])
 AC_REVISION
 
 AC_CONFIG_AUX_DIR(config)
@@ -20,7 +20,7 @@ AC_SUBST(LIBLTDL)
 API_VERSION=0.0
 
 
-AC_DEFINE(LT_SCOPE,[extern],[LibLTDL is linked staticly])      
+AC_DEFINE(LT_SCOPE,[extern],[LibLTDL is linked staticly])
 
 
 
@@ -131,7 +131,7 @@ AC_ARG_ENABLE(layer-profiling,[
        use_layerprofiling="no"
 ])
 if test $use_layerprofiling = "yes" ; then {
-       AC_DEFINE(SYNFIG_PROFILE_LAYERS,[1],[enable layer profiling])   
+       AC_DEFINE(SYNFIG_PROFILE_LAYERS,[1],[enable layer profiling])
 } ; fi
 
 
@@ -233,9 +233,9 @@ if test $with_libdv = "no" ; then {
 # LIBAVCODEC CHECK--------------------
 
 AC_ARG_WITH(libavcodec,[
-  --without-libavcodec         disable support for libavcodec (Default=auto)],[
+  --with-libavcodec         Enable support for libavcodec (Default=no)],[
 ],[
-       with_libavcodec="yes"
+       with_libavcodec="no"
 ])
 
 if test $with_libavcodec != "no" ; then {
@@ -395,14 +395,14 @@ if test $with_jpeg = "no" ; then {
 
 AC_LIB_LTDL
 
-ALL_LINGUAS="es fr ru"
+ALL_LINGUAS="es fr it ru de en_GB zh_CN"
 AM_GNU_GETTEXT([external])
 # This is here so autoreconf will run autopoint
 AM_GNU_GETTEXT_VERSION([0.15])
 localedir="$datadir/locale"
 
-PKG_CHECK_MODULES(ETL, [ETL >= 0.04.12],,[
-       AC_MSG_ERROR([ ** You need to install the ETL (version 0.04.12 or greater).])
+PKG_CHECK_MODULES(ETL, [ETL >= 0.04.13],,[
+       AC_MSG_ERROR([ ** You need to install the ETL (version 0.04.13 or greater).])
 ])
 CONFIG_DEPS="$CONFIG_DEPS ETL"
 
@@ -562,8 +562,8 @@ case "$host" in
                AM_CONDITIONAL(MACOSX_PKG, false)
        ;;
 esac
-               
-               
+
+
 
 # -- H E A D E R S --------------------------------------------
 
@@ -622,8 +622,11 @@ AC_SUBST(CXXFLAGS)
 AC_SUBST(CPPFLAGS)
 AC_SUBST(LDFLAGS)
 
-# this line is required for libtool 1.5.26 but must not be present for libtool 2.2.4...
-AC_CONFIG_SUBDIRS(libltdl)
+# AC_CONFIG_SUBDIRS(libltdl) is required for libtool 1.5.26 but must not be present for
+# libtool 2.2.4. Problem seems to be that AC_LIB_LTDL (above) now calls AC_CONFIG_SUBDIRS
+# itself, through LTDL_INIT, _LTDL_SETUP, _LTDL_MODE_DISPATCH. We need to check the
+# condition that libltdl has already been registered with AC_CONFIG_SUBDIRS:
+m4_ifdef([_AC_SEEN_TAG(libltdl)], [], [AC_CONFIG_SUBDIRS(libltdl)])
 
 CONFIG_LIBS="-lsynfig"
 CONFIG_CFLAGS="$CONFIG_CFLAGS"
@@ -680,7 +683,7 @@ src/modules/mod_png/Makefile
 src/modules/mod_ppm/Makefile
 src/modules/mod_yuv420p/Makefile
 src/modules/mod_svg/Makefile
-src/modules/example/Makefile
+src/modules/mod_example/Makefile
 src/tool/Makefile
 src/modules/synfig_modules.cfg
 examples/walk/Makefile