version 0.3.33
[fms.git] / libs / libtommath / CMakeLists.txt
diff --git a/libs/libtommath/CMakeLists.txt b/libs/libtommath/CMakeLists.txt
new file mode 100644 (file)
index 0000000..20c143d
--- /dev/null
@@ -0,0 +1,131 @@
+CMAKE_MINIMUM_REQUIRED(VERSION 2.4)\r
+IF(COMMAND CMAKE_POLICY)\r
+       CMAKE_POLICY(SET CMP0003 OLD)\r
+ENDIF(COMMAND CMAKE_POLICY)\r
+\r
+PROJECT(libtommath)\r
+\r
+SET(LIBTOMMATH_SRC\r
+bncore.c\r
+bn_error.c\r
+bn_fast_mp_invmod.c\r
+bn_fast_mp_montgomery_reduce.c\r
+bn_fast_s_mp_mul_digs.c\r
+bn_fast_s_mp_mul_high_digs.c\r
+bn_fast_s_mp_sqr.c\r
+bn_mp_2expt.c\r
+bn_mp_abs.c\r
+bn_mp_add.c\r
+bn_mp_addmod.c\r
+bn_mp_add_d.c\r
+bn_mp_and.c\r
+bn_mp_clamp.c\r
+bn_mp_clear.c\r
+bn_mp_clear_multi.c\r
+bn_mp_cmp.c\r
+bn_mp_cmp_d.c\r
+bn_mp_cmp_mag.c\r
+bn_mp_cnt_lsb.c\r
+bn_mp_copy.c\r
+bn_mp_count_bits.c\r
+bn_mp_div.c\r
+bn_mp_div_2.c\r
+bn_mp_div_2d.c\r
+bn_mp_div_3.c\r
+bn_mp_div_d.c\r
+bn_mp_dr_is_modulus.c\r
+bn_mp_dr_reduce.c\r
+bn_mp_dr_setup.c\r
+bn_mp_exch.c\r
+bn_mp_exptmod.c\r
+bn_mp_exptmod_fast.c\r
+bn_mp_expt_d.c\r
+bn_mp_exteuclid.c\r
+bn_mp_fread.c\r
+bn_mp_fwrite.c\r
+bn_mp_gcd.c\r
+bn_mp_get_int.c\r
+bn_mp_grow.c\r
+bn_mp_init.c\r
+bn_mp_init_copy.c\r
+bn_mp_init_multi.c\r
+bn_mp_init_set.c\r
+bn_mp_init_set_int.c\r
+bn_mp_init_size.c\r
+bn_mp_invmod.c\r
+bn_mp_invmod_slow.c\r
+bn_mp_is_square.c\r
+bn_mp_jacobi.c\r
+bn_mp_karatsuba_mul.c\r
+bn_mp_karatsuba_sqr.c\r
+bn_mp_lcm.c\r
+bn_mp_lshd.c\r
+bn_mp_mod.c\r
+bn_mp_mod_2d.c\r
+bn_mp_mod_d.c\r
+bn_mp_montgomery_calc_normalization.c\r
+bn_mp_montgomery_reduce.c\r
+bn_mp_montgomery_setup.c\r
+bn_mp_mul.c\r
+bn_mp_mulmod.c\r
+bn_mp_mul_2.c\r
+bn_mp_mul_2d.c\r
+bn_mp_mul_d.c\r
+bn_mp_neg.c\r
+bn_mp_n_root.c\r
+bn_mp_or.c\r
+bn_mp_prime_fermat.c\r
+bn_mp_prime_is_divisible.c\r
+bn_mp_prime_is_prime.c\r
+bn_mp_prime_miller_rabin.c\r
+bn_mp_prime_next_prime.c\r
+bn_mp_prime_rabin_miller_trials.c\r
+bn_mp_prime_random_ex.c\r
+bn_mp_radix_size.c\r
+bn_mp_radix_smap.c\r
+bn_mp_rand.c\r
+bn_mp_read_radix.c\r
+bn_mp_read_signed_bin.c\r
+bn_mp_read_unsigned_bin.c\r
+bn_mp_reduce.c\r
+bn_mp_reduce_2k.c\r
+bn_mp_reduce_2k_l.c\r
+bn_mp_reduce_2k_setup.c\r
+bn_mp_reduce_2k_setup_l.c\r
+bn_mp_reduce_is_2k.c\r
+bn_mp_reduce_is_2k_l.c\r
+bn_mp_reduce_setup.c\r
+bn_mp_rshd.c\r
+bn_mp_set.c\r
+bn_mp_set_int.c\r
+bn_mp_shrink.c\r
+bn_mp_signed_bin_size.c\r
+bn_mp_sqr.c\r
+bn_mp_sqrmod.c\r
+bn_mp_sqrt.c\r
+bn_mp_sub.c\r
+bn_mp_submod.c\r
+bn_mp_sub_d.c\r
+bn_mp_toom_mul.c\r
+bn_mp_toom_sqr.c\r
+bn_mp_toradix.c\r
+bn_mp_toradix_n.c\r
+bn_mp_to_signed_bin.c\r
+bn_mp_to_signed_bin_n.c\r
+bn_mp_to_unsigned_bin.c\r
+bn_mp_to_unsigned_bin_n.c\r
+bn_mp_unsigned_bin_size.c\r
+bn_mp_xor.c\r
+bn_mp_zero.c\r
+bn_prime_tab.c\r
+bn_reverse.c\r
+bn_s_mp_add.c\r
+bn_s_mp_exptmod.c\r
+bn_s_mp_mul_digs.c\r
+bn_s_mp_mul_high_digs.c\r
+bn_s_mp_sqr.c\r
+bn_s_mp_sub.c\r
+)\r
+\r
+INCLUDE_DIRECTORIES(.)\r
+ADD_LIBRARY(tommath ${LIBTOMMATH_SRC})\r