Add gnome-extra/link-monitor-applet-3.0.
[overlay.git] / gnome-extra / link-monitor-applet / link-monitor-applet-3.0.ebuild
1 # Copyright 2004-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit gnome2 eutils autotools
6
7 DESCRIPTION="A round-trip time monitor"
8 HOMEPAGE="http://www.nongnu.org/link-monitor/"
9 SRC_URI="http://savannah.nongnu.org/download/link-monitor/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE="ipv6 geoip"
15
16 RDEPEND=">=x11-libs/gtk+-2.8.0
17         >=dev-libs/glib-2.4
18         >=gnome-base/libgnomeui-2.4
19         >=gnome-base/gnome-panel-2.4
20         >=gnome-base/libglade-2.0
21         >=gnome-base/gconf-2.0
22         geoip? ( dev-libs/geoip )"
23 DEPEND="$RDEPEND"
24
25 G2CONF="$(use_enable ipv6)
26         $(use_enable geoip)"
27
28 src_unpack() {
29     unpack ${P}.tar.bz2
30     cd "${S}"
31     ./jb configure destdir="${D}" || die "config failed"
32 }
33
34 src_compile() {
35     ./jb build || die "build failed"
36 }
37
38 src_install() {
39     ./jb install || die "install failed"
40 }
41