Add ebuild for net-misc/trickle-1.06.
[overlay.git] / net-misc / trickle / trickle-1.06.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils autotools
8
9 DESCRIPTION="portable lightweight userspace bandwidth shaper"
10 HOMEPAGE="http://monkey.org/~marius/pages/?page=trickle"
11 SRC_URI="http://monkey.org/~marius/trickle/${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 DEPEND="dev-libs/libevent"
19
20 src_prepare() {
21         epatch "${FILESDIR}/${P}-libobjs.diff"
22         epatch "${FILESDIR}/${P}-overloadDATA.diff"
23         epatch "${FILESDIR}/${P}-automake-cflags.diff"
24         epatch "${FILESDIR}/${P}-in_addr_t.diff"
25
26         eautoreconf
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install
31 }