Fix epatch invocation again, add missing files.
[overlay.git] / net-p2p / amule / amule-2.2.6.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.6.ebuild,v 1.1 2009/09/18 14:59:45 patrick Exp $
4
5 EAPI="2"
6
7 inherit eutils flag-o-matic wxwidgets
8
9 MY_P=${PN/m/M}-${PV}
10 S="${WORKDIR}"/${MY_P}
11
12 DESCRIPTION="aMule, the all-platform eMule p2p client"
13 HOMEPAGE="http://www.amule.org/"
14 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
19 IUSE="daemon debug geoip gtk nls remote stats unicode upnp"
20
21 DEPEND="=x11-libs/wxGTK-2.8*
22         =dev-libs/crypto++-5.5*
23         >=sys-libs/zlib-1.2.1
24         stats? ( >=media-libs/gd-2.0.26[jpeg] )
25         geoip? ( dev-libs/geoip )
26         upnp? ( >=net-libs/libupnp-1.6.6 )
27         remote? ( >=media-libs/libpng-1.2.0
28         unicode? ( >=media-libs/gd-2.0.26 ) )"
29
30 pkg_setup() {
31         if ! use gtk && ! use remote && ! use daemon; then
32                 eerror ""
33                 eerror "You have to specify at least one of gtk, remote or daemon"
34                 eerror "USE flag to build amule."
35                 eerror ""
36                 die "Invalid USE flag set"
37         fi
38
39         if use stats && ! use gtk; then
40                 einfo "Note: You would need both the gtk and stats USE flags"
41                 einfo "to compile aMule Statistics GUI."
42                 einfo "I will now compile console versions only."
43         fi
44 }
45
46 pkg_preinst() {
47         if use daemon || use remote; then
48                 enewgroup p2p
49                 enewuser p2p -1 -1 /home/p2p p2p
50         fi
51 }
52
53 src_configure() {
54         local myconf
55
56         WX_GTK_VER="2.8"
57
58         if use gtk; then
59                 einfo "wxGTK with gtk support will be used"
60                 need-wxwidgets unicode
61         else
62                 einfo "wxGTK without X support will be used"
63                 need-wxwidgets base
64         fi
65
66         if use gtk ; then
67                 use stats && myconf="${myconf}
68                         --enable-wxcas
69                         --enable-alc"
70                 use remote && myconf="${myconf}
71                         --enable-amule-gui"
72         else
73                 myconf="
74                         --disable-monolithic
75                         --disable-amule-gui
76                         --disable-wxcas
77                         --disable-alc"
78         fi
79
80         epatch "${FILESDIR}/${PN}-2.2.6-remove-download-limit.patch"
81
82         econf \
83                 --with-wx-config=${WX_CONFIG} \
84                 --with-wxbase-config=${WX_CONFIG} \
85                 --enable-amulecmd \
86                 $(use_enable debug) \
87                 $(use_enable !debug optimize) \
88                 $(use_enable daemon amule-daemon) \
89                 $(use_enable geoip) \
90                 $(use_enable nls) \
91                 $(use_enable remote webserver) \
92                 $(use_enable stats cas) \
93                 $(use_enable stats alcc) \
94                 ${myconf} || die
95 }
96
97 src_install() {
98         emake DESTDIR="${D}" install || die
99
100         if use daemon; then
101                 newconfd "${FILESDIR}"/amuled.confd amuled
102                 newinitd "${FILESDIR}"/amuled.initd amuled
103         fi
104         if use remote; then
105                 newconfd "${FILESDIR}"/amuleweb.confd amuleweb
106                 newinitd "${FILESDIR}"/amuleweb.initd amuleweb
107         fi
108 }