Add x11-base/xorg-drivers-1.7.
[overlay.git] / x11-base / xorg-drivers / xorg-drivers-1.7.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-drivers/xorg-drivers-1.7.ebuild,v 1.1 2009/10/02 15:10:30 scarabeus Exp $
4
5 DESCRIPTION="Meta package containing deps on all xorg drivers"
6 HOMEPAGE="http://www.gentoo.org/"
7 SRC_URI=""
8
9 LICENSE="as-is"
10 SLOT="0"
11 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
12
13 IUSE_INPUT_DEVICES="
14         input_devices_acecad
15         input_devices_aiptek
16         input_devices_citron
17         input_devices_elographics
18         input_devices_evdev
19         input_devices_fpit
20         input_devices_hyperpen
21         input_devices_joystick
22         input_devices_keyboard
23         input_devices_mouse
24         input_devices_mutouch
25         input_devices_penmount
26         input_devices_tslib
27         input_devices_virtualbox
28         input_devices_vmmouse
29         input_devices_void
30         input_devices_synaptics
31         input_devices_wacom
32         input_devices_wizardpen
33 "
34 IUSE_VIDEO_CARDS="
35         video_cards_apm
36         video_cards_ark
37         video_cards_ast
38         video_cards_chips
39         video_cards_cirrus
40         video_cards_dummy
41         video_cards_epson
42         video_cards_fbdev
43         video_cards_geode
44         video_cards_glint
45         video_cards_i128
46         video_cards_i740
47         video_cards_intel
48         video_cards_impact
49         video_cards_imstt
50         video_cards_mach64
51         video_cards_mga
52         video_cards_neomagic
53         video_cards_newport
54         video_cards_nv
55         video_cards_r128
56         video_cards_radeon
57         video_cards_radeonhd
58         video_cards_rendition
59         video_cards_s3
60         video_cards_s3virge
61         video_cards_savage
62         video_cards_siliconmotion
63         video_cards_sis
64         video_cards_sisusb
65         video_cards_sunbw2
66         video_cards_suncg14
67         video_cards_suncg3
68         video_cards_suncg6
69         video_cards_sunffb
70         video_cards_sunleo
71         video_cards_suntcx
72         video_cards_tdfx
73         video_cards_tga
74         video_cards_trident
75         video_cards_tseng
76         video_cards_v4l
77         video_cards_vermilion
78         video_cards_vesa
79         video_cards_via
80         video_cards_virtualbox
81         video_cards_vmware
82         video_cards_voodoo
83         video_cards_xgi
84         video_cards_fglrx
85         video_cards_nvidia
86 "
87
88 IUSE="${IUSE_VIDEO_CARDS} ${IUSE_INPUT_DEVICES}"
89
90 PDEPEND="
91         input_devices_acecad?      ( x11-drivers/xf86-input-acecad )
92         input_devices_aiptek?      ( x11-drivers/xf86-input-aiptek )
93         input_devices_citron?      ( x11-drivers/xf86-input-citron )
94         input_devices_elographics? ( x11-drivers/xf86-input-elographics )
95         input_devices_evdev?       ( x11-drivers/xf86-input-evdev )
96         input_devices_fpit?        ( x11-drivers/xf86-input-fpit )
97         input_devices_hyperpen?    ( x11-drivers/xf86-input-hyperpen )
98         input_devices_joystick?    ( x11-drivers/xf86-input-joystick )
99         input_devices_keyboard?    ( x11-drivers/xf86-input-keyboard )
100         input_devices_mouse?       ( x11-drivers/xf86-input-mouse )
101         input_devices_mutouch?     ( x11-drivers/xf86-input-mutouch )
102         input_devices_penmount?    ( x11-drivers/xf86-input-penmount )
103         input_devices_tslib?       ( x11-drivers/xf86-input-tslib )
104         input_devices_virtualbox?  ( x11-drivers/xf86-input-virtualbox )
105         input_devices_vmmouse?     ( x11-drivers/xf86-input-vmmouse )
106         input_devices_void?        ( x11-drivers/xf86-input-void )
107         input_devices_synaptics?   ( x11-drivers/xf86-input-synaptics )
108         input_devices_wacom?       ( x11-drivers/linuxwacom )
109         input_devices_wizardpen?   ( x11-drivers/wizardpen )
110
111         video_cards_apm?           ( x11-drivers/xf86-video-apm )
112         video_cards_ark?           ( x11-drivers/xf86-video-ark )
113         video_cards_ast?           ( x11-drivers/xf86-video-ast )
114         video_cards_chips?         ( x11-drivers/xf86-video-chips )
115         video_cards_cirrus?        ( x11-drivers/xf86-video-cirrus )
116         video_cards_dummy?         ( x11-drivers/xf86-video-dummy )
117         video_cards_fbdev?         ( x11-drivers/xf86-video-fbdev )
118         video_cards_geode?         ( x11-drivers/xf86-video-geode )
119         video_cards_glint?         ( x11-drivers/xf86-video-glint )
120         video_cards_i128?          ( x11-drivers/xf86-video-i128 )
121         video_cards_i740?          ( x11-drivers/xf86-video-i740 )
122         video_cards_intel?         ( x11-drivers/xf86-video-intel )
123         video_cards_mach64?        ( x11-drivers/xf86-video-mach64 )
124         video_cards_mga?           ( x11-drivers/xf86-video-mga )
125         video_cards_neomagic?      ( x11-drivers/xf86-video-neomagic )
126         video_cards_newport?       ( x11-drivers/xf86-video-newport )
127         video_cards_nv?            ( x11-drivers/xf86-video-nv )
128         video_cards_nvidia?        ( x11-drivers/nvidia-drivers )
129         video_cards_fglrx?         ( x11-drivers/ati-drivers )
130         video_cards_r128?          ( x11-drivers/xf86-video-r128 )
131         video_cards_radeon?        ( x11-drivers/xf86-video-ati )
132         video_cards_radeonhd?      ( x11-drivers/xf86-video-radeonhd )
133         video_cards_rendition?     ( x11-drivers/xf86-video-rendition )
134         video_cards_s3?            ( x11-drivers/xf86-video-s3 )
135         video_cards_s3virge?       ( x11-drivers/xf86-video-s3virge )
136         video_cards_savage?        ( x11-drivers/xf86-video-savage )
137         video_cards_siliconmotion? ( x11-drivers/xf86-video-siliconmotion )
138         video_cards_sis?           ( x11-drivers/xf86-video-sis )
139         video_cards_sisusb?        ( x11-drivers/xf86-video-sisusb )
140         video_cards_sunffb?        ( x11-drivers/xf86-video-sunffb )
141         video_cards_sunleo?        ( x11-drivers/xf86-video-sunleo )
142         video_cards_tdfx?          ( x11-drivers/xf86-video-tdfx )
143         video_cards_tga?           ( x11-drivers/xf86-video-tga )
144         video_cards_trident?       ( x11-drivers/xf86-video-trident )
145         video_cards_tseng?         ( x11-drivers/xf86-video-tseng )
146         video_cards_v4l?           ( x11-drivers/xf86-video-v4l )
147         video_cards_vesa?          ( x11-drivers/xf86-video-vesa )
148         video_cards_via?           ( x11-drivers/xf86-video-openchrome )
149         video_cards_virtualbox?    ( x11-drivers/xf86-video-virtualbox )
150         video_cards_vmware?        ( x11-drivers/xf86-video-vmware )
151         video_cards_voodoo?        ( x11-drivers/xf86-video-voodoo )
152         video_cards_xgi?           ( x11-drivers/xf86-video-xgi )
153
154         !x11-drivers/xf86-video-impact
155         !x11-drivers/xf86-video-imstt
156         !x11-drivers/xf86-video-sunbw2
157         !x11-drivers/xf86-video-suncg14
158         !x11-drivers/xf86-video-suncg3
159         !x11-drivers/xf86-video-suncg6
160         !x11-drivers/xf86-video-suntcx
161         !x11-drivers/xf86-video-vermilion
162         !x11-drivers/xf86-video-cyrix
163         !x11-drivers/xf86-video-nsc
164         !x11-drivers/xf86-video-vga
165 "